Get in touch
Back
Maintenance

Updating infrastructure

Completed 31 Dec at 10:07am EST.

https://smartersends.com
Completed

Maintenance is now complete. Happy New Year!

Posted 31 Dec at 10:07am EST.
Started

We are currently updating some infrastructure to ring in the new year. We should be back online in less than an hour

Posted 31 Dec at 09:38am EST.